Results 1 to 3 of 3

Thread: EC25 engine cuts out when hydraulic fluid gets hot?

  1. #1

    EC25 engine cuts out when hydraulic fluid gets hot?

    I have an EC25 Volvo and I can start it easily when it is cold and it works perfectly but after about ten minutes, when the hydraulic fluid gets hot, the engine stalls and will not restart, it is also very hard to turn over on the key. Once it has cooled down, it will work again for 10 minutes?
    I have put on a new filter and there is plenty of hydraulic fluid in it. The hydraulic intercooler doesn`t get any where near as hot as the pump on the engine. If I disconnect the hydraulics to the pump... (aside from getting covered in hydraulic oil) the engine will start.
    Any ideas please?

  2. #2
    Tartan paint and sky hook supplier .. also long stands Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,003
    If I remember correctly ,.. The machine is fitted with a variable displacement pump, which has a 'no load' valve fitted to it to make the swash plate return to zero every time the machine is switched off in order to not load the starter motor should a service be opened during start procedure, it sounds like that valve is stuck. can you take a picture of the pump ?
    Please don't PM me for plant advice.. thanks Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help lots of others, which is why we exist

  3. #3
    Apprentice joiner
    Join Date
    Nov 2014
    Location
    Guildford, Surrey
    Posts
    102
    Quote Originally Posted by Richard Dye View Post
    I have an EC25 Volvo and I can start it easily when it is cold and it works perfectly but after about ten minutes, when the hydraulic fluid gets hot, the engine stalls and will not restart, it is also very hard to turn over on the key. Once it has cooled down, it will work again for 10 minutes?
    I have put on a new filter and there is plenty of hydraulic fluid in it. The hydraulic intercooler doesn`t get any where near as hot as the pump on the engine. If I disconnect the hydraulics to the pump... (aside from getting covered in hydraulic oil) the engine will start.
    Any ideas please?
    Hi Richard,

    Just check to see that the hammer pedal is in a neutral position, and all functions are operating correctly!

    Mick

Similar Threads

  1. volvo ec25 one track wont turn
    By oggy307 in forum Hydraulics
    Replies: 6
    Last Post: 18-11-2013, 07:09 PM
  2. Problem with EC25
    By Olav in forum Hydraulics
    Replies: 3
    Last Post: 29-07-2013, 09:08 AM
  3. Volvo EC15B cuts out
    By jackpreacher in forum Damn! its Broken ........ again ..!!
    Replies: 12
    Last Post: 28-06-2013, 06:23 PM
  4. Volvo EC25 Hydraulic Relief Adjustment?
    By dicklund2 in forum Hydraulics
    Replies: 6
    Last Post: 26-06-2013, 07:04 PM
  5. Volco ec25, hydraulic problems!
    By oleasx in forum Damn! its Broken ........ again ..!!
    Replies: 12
    Last Post: 01-05-2013, 12:56 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •