Results 1 to 7 of 7

Thread: Volvo ec25 2007 Main boom lowering

  1. #1

    Unhappy Volvo ec25 2007 Main boom lowering

    Hello My volvo ec25 2007 excavator main boom is lowering by itself, i am thinking that my slide in my Valve block has been worn? I can dig with it but it is lowering 5cm. Every min. When main boom is standing still. Does anybody have any idea what is wrong?I can se that my seals i leaking on my boom cylinder also a little bit. Have just bought a seal kit and hopping this many fix it.

  2. #2
    Quote Originally Posted by Lauritz View Post
    Hello My volvo ec25 2007 excavator main boom is lowering by itself, i am thinking that my slide in my Valve block has been worn? I can dig with it but it is lowering 5cm. Every min. When main boom is standing still. Does anybody have any idea what is wrong?I can se that my seals i leaking on my boom cylinder also a little bit. Have just bought a seal kit and hopeing this many fix it.
    Many Thanks for all help here.

  3. #3
    Building Site Manager Stock's Avatar
    Join Date
    Feb 2011
    Location
    Hibernia.......The PRC
    Posts
    1,922
    What hours are on the machine?
    A driven man with a burning passion.

  4. #4
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,369
    Quote Originally Posted by Lauritz View Post
    Hello My volvo ec25 2007 excavator main boom is lowering by itself, i am thinking that my slide in my Valve block has been worn? I can dig with it but it is lowering 5cm. Every min. When main boom is standing still. Does anybody have any idea what is wrong?I can se that my seals i leaking on my boom cylinder also a little bit. Have just bought a seal kit and hopping this many fix it.
    Quote Originally Posted by Lauritz View Post
    Many Thanks for all help here.
    Hey fella .. you might want to have a bit more respect ? .. not all of us hog a keyboard all day and you only joined this forum 6 hours ago

    Yours seals are not good but that isnt the problem as they are on the return side of the equation .. ie to pressurise the boom down..... your failure is a different issue .. want any more help ?
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  5. #5
    Quote Originally Posted by Stock View Post
    What hours are on the machine?
    Hi thankyou i have 3000 hours on machine many Thanks

  6. #6
    Quote Originally Posted by Muz View Post
    Hey fella .. you might want to have a bit more respect ? .. not all of us hog a keyboard all day and you only joined this forum 6 hours ago

    Yours seals are not good but that isnt the problem as they are on the return side of the equation .. ie to pressurise the boom down..... your failure is a different issue .. want any more help ?
    Ok sorry, many Thanks for all the help i recive here on the forum. I am greatful for all answers. I have thinking of opening the element on the hydraulikk Valve block on the main boom position, to see if i can change o rings on sliding sleve. Or is my solnoid not closing enough?

  7. #7
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,369
    Quote Originally Posted by Lauritz View Post
    Ok sorry, many Thanks for all the help i recive here on the forum. I am greatful for all answers. I have thinking of opening the element on the hydraulikk Valve block on the main boom position, to see if i can change o rings on sliding sleve. Or is my solnoid not closing enough?
    Simple things first ... A likely cause will be oil bypassing the seal pack inside the ram. To make sure it is this, before doing anything else and giving yourself a pile of un necessary work lower the boom onto a raised block and relax all the hydraulics... disconnect the feed and return pipes, and seal the ram off, or connect the feed to the return on the ram to seal it and knock the block out from under the bucket .. if after time the bucket has lowered, that's your problem as described above. If it doesen't move, then you know the fault is at the valve block end, and you have eliminated the ram.
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

Similar Threads

  1. volvo ec25 one track wont turn
    By oggy307 in forum Hydraulics
    Replies: 6
    Last Post: 18-11-2013, 07:09 PM
  2. JCB 3CX boom shims
    By bobbyc in forum Help With Parts or Parts Sourcing
    Replies: 2
    Last Post: 27-08-2013, 01:50 PM
  3. Volvo EC25 Hydraulic Relief Adjustment?
    By dicklund2 in forum Hydraulics
    Replies: 6
    Last Post: 26-06-2013, 07:04 PM
  4. Main casting of my JCB 8018 Broken!
    By Wee Jim in forum Damn! its Broken ........ again ..!!
    Replies: 55
    Last Post: 10-02-2013, 01:03 PM
  5. Hyd Tank Covers for Volvo EC25, EC45, EC30
    By Muz in forum Plant or parts for Sale
    Replies: 0
    Last Post: 27-02-2012, 02:41 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •