Results 1 to 4 of 4

Thread: Lifton 750 Load Star Drive issue

  1. #1

    Lifton 750 Load Star Drive issue

    Hi to anyone who can help, I purchased a lifton 750 which works great but the problem is it has been converted to run on a handle accelerator rather than the accelerator pedal.

    So when you start the dumper and engage forward it will only accelerate using the handle that has been fitted and not the accelerator pedal which has been totally disconnected. I assume this has been done to overcome a fault in the hydraulic gearbox rather than have it repaired correctly. When drive is disengaged ( put into neutral )the wheels lock straight away like the brakes have been applied

    If anyone has had the same problem and could point me in the right direction then any advice would be greatly appreciated.


    Kind regards
    Lee

  2. #2
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,297
    They never had a neutral as such .. just a lesser amount of 'drive' until no drive was called for .I take it , it moves forwards and back ok ? Jack up both axles together and put it in drive and see what happens ? .. has it been converted to two wheel drive by chance ?
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  3. #3

    Lee lifton

    All wheels are driving and plenty of power but would like to repair it so all works with accelerator pedal. It drives in reverse and forward but you need to lower the accelerator to tick over or it would throw you off the machine when selecting neutral.

  4. #4
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,297
    Have you jacked up the axles both at the same time yet ? (please keep to this one thread with your questions)
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

Similar Threads

  1. lifton LS750 drive Problem
    By saabjeff in forum Hydraulics
    Replies: 4
    Last Post: 06-08-2018, 10:49 PM
  2. Lifton LS750 Dumper Yanmar and Hydrostacic drive
    By Greentiles in forum Damn! its Broken ........ again ..!!
    Replies: 17
    Last Post: 12-08-2015, 06:58 PM
  3. Lifton -no drive
    By dmhk2005 in forum Damn! its Broken ........ again ..!!
    Replies: 31
    Last Post: 18-12-2013, 11:15 PM
  4. lifton ls750 no drive
    By daz in forum Hydraulics
    Replies: 8
    Last Post: 15-12-2013, 10:48 PM
  5. Lifton LS850 wont drive uphill
    By Stevey in forum Damn! its Broken ........ again ..!!
    Replies: 142
    Last Post: 19-08-2013, 06:30 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •