Results 1 to 5 of 5

Thread: Sumitomo excavator control unit - broken

  1. #1

    Exclamation Sumitomo excavator control unit - broken

    Hey guys,
    I own a phone and computer repair shop.. A client brought me a control unit for a sumitomo excavator (photos in link below)
    The issue is that it wont display the rear camera to the operator
    We tested a different control unit in the excavator and it worked fine so we have determined its a motherboard fault in this one
    its ~4000 to replace the unit so ideally we want to fix this one
    the problem is I have no access to schematics for this and cant find anything about it online..
    its probably something as easy as swapping a chip but I cant do anything until i know what chip does what..
    Does anyone here have any recommendations as to what i should do next?
    As you can imagine im feeling a bit out of my depth on this one.. phone repairs i can do just fine but excavator repairs are new to me!
    https://imgur.com/a/FLZakLv

  2. #2
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,352
    Quote Originally Posted by MidletonIT View Post
    Hey guys,
    I own a phone and computer repair shop.. A client brought me a control unit for a sumitomo excavator (photos in link below)
    The issue is that it wont display the rear camera to the operator
    We tested a different control unit in the excavator and it worked fine so we have determined its a motherboard fault in this one
    its ~4000 to replace the unit so ideally we want to fix this one
    the problem is I have no access to schematics for this and cant find anything about it online..
    its probably something as easy as swapping a chip but I cant do anything until i know what chip does what..
    Does anyone here have any recommendations as to what i should do next?
    As you can imagine im feeling a bit out of my depth on this one.. phone repairs i can do just fine but excavator repairs are new to me!
    https://imgur.com/a/FLZakLv
    Welcome .. Sumitomo wont help because they didnt make this item clearly ... so who ever makes the control unit is where you will have to go. Sadly as I have found , big companies are very good at making their product suppliers remove any designations from the stuff they make for them .. (although not always) so you might find it hard to ascertain who made it.

    Apart from basic microelectronics knowledge which you clearly have, the best I can suggest is that a failure would most likely be caused by its environment with vibration or dirt or water ingress. I assume you have removed the board to look for dry joints, corrosion etc ? and if so, are there any makers marks on it ?
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  3. #3
    Quote Originally Posted by Muz View Post
    Welcome .. Sumitomo wont help because they didnt make this item clearly ... so who ever makes the control unit is where you will have to go. Sadly as I have found , big companies are very good at making their product suppliers remove any designations from the stuff they make for them .. (although not always) so you might find it hard to ascertain who made it.

    Apart from basic microelectronics knowledge which you clearly have, the best I can suggest is that a failure would most likely be caused by its environment with vibration or dirt or water ingress. I assume you have removed the board to look for dry joints, corrosion etc ? and if so, are there any makers marks on it ?

    Thank you for the response..

    I have contacted sumitomo and have asked for the schematics for the board.. i am waiting for their response but i think it is unlikely they will release them to me

    I did a little bit more searching online and i think the manufacturer for the unit is "Case Construction" https://www.casece.com/emea/en-uk
    I will attempt to contact them tomorrow

    there is no markings on the board itself to tell me who manufactured it.. there are random numbers but they get no results when i type them in to google

    I removed the board and inspected it under the microscope and i cant find any issues at all.. It was spotless .. no signs of liquid damage and all pins are soldered to the board correctly..

    I took some measurements with my multimeter and cant detect any shorts on the board..

    and as far as i can tell they dont sell replacement boards.. only full units

  4. #4
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,352
    Quote Originally Posted by MidletonIT View Post
    Thank you for the response..

    I have contacted sumitomo and have asked for the schematics for the board.. i am waiting for their response but i think it is unlikely they will release them to me

    They wont/cant because they wont have made the thing


    Quote Originally Posted by MidletonIT View Post
    I did a little bit more searching online and i think the manufacturer for the unit is "Case Construction" https://www.casece.com/emea/en-uk
    Case are a manufacturer like sumitomo .. they dont do microelectronics as far as I know ... they would out source that stuff to a specialist


    Quote Originally Posted by MidletonIT View Post
    and as far as i can tell they dont sell replacement boards.. only full units
    Welcome to the world of plant .. as usual it will be a simple and small component failure like a resistor going high in value, and you are stuffed without being able to find who made it to get the schematic ... may be you will have to be a bit more forensic ....any logos on the board ? mitsubishi etc ?
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  5. #5
    Ganger Wazza's Avatar
    Join Date
    Aug 2011
    Location
    Under The Southern Cross
    Posts
    627
    Its almost criminal what they charge for some parts these days ,easiest solution might be to install an aftermarket rear camera if practicle.
    Or flick through Alibaba pages and find non oem replacement board if they have one .

Similar Threads

  1. Sumitomo sh145u manual
    By Tossle in forum Everything Excavators
    Replies: 1
    Last Post: 19-01-2019, 09:00 PM
  2. Jcb 3cx fuel sender unit
    By hoonhall in forum Everything Excavators
    Replies: 3
    Last Post: 08-05-2017, 09:21 PM
  3. Sumitomo SH75u-2 1999
    By hebridian in forum Everything Excavators
    Replies: 5
    Last Post: 06-02-2017, 10:17 PM
  4. Excavator exhaust fume control
    By Muz in forum Everything Excavators
    Replies: 2
    Last Post: 18-01-2014, 07:51 PM
  5. Hooooooly shit I need this tractor unit
    By Dan in forum All Plant Youtube clips / Pictures
    Replies: 5
    Last Post: 27-02-2011, 10:21 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •