Results 1 to 3 of 3

Thread: Jcb 8060 2006

  1. #1
    New Start
    Join Date
    Apr 2019
    Posts
    1

    Jcb 8060 2006

    Anyone help jcb 8060 starts and runs but as soon as any load is put on arms bucket or even when tracking engine starts to die and even stalls .

  2. #2
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,339
    Welcome .. Need to investigate the fuel supply .. what have you checked so far ?
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  3. #3
    Fabrication Guru +1 v8druid's Avatar
    Join Date
    Apr 2015
    Location
    Druid central, just East of Pandy, Nr. Abergavenny, S. Wales, UK, 3rd rock from the Sun
    Posts
    2,703
    Quote Originally Posted by Buton View Post
    Anyone help jcb 8060 starts and runs but as soon as any load is put on arms bucket or even when tracking engine starts to die and even stalls .
    Welcome ..... what had you done prior to the fault manifesting? fuel system service ? filled the tank?
    If it's got tracks, wheels, t*ts, or an engine, at some point it's gonna give you trouble!!

Similar Threads

  1. jcb fuel tank senders dont last. as fitted to 8020, 8060,801 .
    By roger8085 in forum Everything Excavators
    Replies: 2
    Last Post: 03-04-2013, 09:47 PM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •