Results 1 to 3 of 3

Thread: Possible Slew Braking Issue

  1. #1

    Possible Slew Braking Issue

    Hello All,

    Just bought a second-hand Takeuchi TB016 mini digger with 3700 hours on it. Everything seems good apart from there's a delay with the slew start/stop.

    Specifically:

    When I initiate a slew, it begins turning straight away as normal, but when I let go of the control, it follows through somewhat before coming to a stop. Also, when I turn the digger on the spot using the tracks, there is a delay in the superstructure following through. I've extended the arm and checked for excessive play but in my inexperienced opinion, it seems OK.

    Any advice would be greatly appreciated.

    Thanks!

  2. #2
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,341
    Welcome .. Kinda hard to know from your description whether its doing as it should, or not, we'd need to see a wee video of it. All machines vary in their operational characteristics, are you comparing it to a machine youve used before ?
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  3. #3
    Quote Originally Posted by Muz View Post
    Welcome .. Kinda hard to know from your description whether its doing as it should, or not, we'd need to see a wee video of it. All machines vary in their operational characteristics, are you comparing it to a machine youve used before ?
    Hi Muz,

    Thanks for getting back. Yes, specifically comparing to a Takeuchi TB014 I've used a fair bit. Will get a video up!

Similar Threads

  1. Lifton 750 Load Star Drive issue
    By Lee Lifton in forum Hydraulics
    Replies: 3
    Last Post: 18-02-2019, 05:55 PM
  2. Hanix 15b-2: Strange Tracking Issue
    By mowgli in forum Damn! its Broken ........ again ..!!
    Replies: 93
    Last Post: 18-12-2018, 11:58 AM
  3. Benford 1-71HE Pedestrian Single Roller Clutch issue
    By AndrewMawson in forum Damn! its Broken ........ again ..!!
    Replies: 2
    Last Post: 01-03-2018, 02:01 AM
  4. JCB 8018 dipper issue
    By vfr98 in forum Everything Excavators
    Replies: 22
    Last Post: 26-03-2015, 11:11 PM
  5. Quick hitch issue
    By Vinpetrol in forum Everything Excavators
    Replies: 2
    Last Post: 12-03-2013, 03:26 AM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •