Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: Kubota KX 080 slew

  1. #1

    Kubota KX 080 slew

    My 2016 Kubota kx80-4 is jumpy/jerky while slewing, has anyone had this problem or know why itís happening?

  2. #2
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,395
    Quote Originally Posted by Donnan19 View Post
    My 2016 Kubota kx80-4 is jumpy/jerky while slewing, has anyone had this problem or know why it’s happening?

    Welcome.. One thread, one question please, I've deleted your other one .. do you mean a KX 080 8 tonner ?
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  3. #3
    Yea its a Kubota kx080-4 8 tonne.

  4. #4
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,395
    How many hours are on it .. yours from new ? need a lot more info .. could be a multitude of reasons for the problem (not saying I have the answer but cant diagnose without info) for example ... are you talking about the offset or the whole machine ? have you checked the oil levels .. etc..etc...etc
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  5. #5
    Bought it with 1500hrs, thereís now 2200hrs on it. Itís the whole machine while slewing, if your not extra careful while starting to slew or while easing off slewing it will be jumpy and not very smooth. Oil levels are ok. Iíve just been told to change the servo filter and check bowl for filings so will do that Monday morning.

  6. #6
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,395
    Quote Originally Posted by Donnan19 View Post
    Bought it with 1500hrs, thereís now 2200hrs on it. Itís the whole machine while slewing, if your not extra careful while starting to slew or while easing off slewing it will be jumpy and not very smooth. Oil levels are ok. Iíve just been told to change the servo filter and check bowl for filings so will do that Monday morning.
    Ok I have two of them currently (dash 3) and no problems so far in this area both up to 5000 hours or so ...my first suggestion would have been the filters first also but with those hours, thats not your problem, its something else.


    When you look at the hyd oil level bar on the tank can you see any air bubbles/ white or does the oil look solid yellow ?
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  7. #7
    Fabrication Guru +1 v8druid's Avatar
    Join Date
    Apr 2015
    Location
    Druid central, just East of Pandy, Nr. Abergavenny, S. Wales, UK, 3rd rock from the Sun
    Posts
    2,818
    slew brake ? servo pressures down ?
    If it's got tracks, wheels, t*ts, or an engine, at some point it's gonna give you trouble!!

  8. #8
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,395
    Tell you one severe problem I did have with one of them, dont think its relevant here but just to let you know...For some reason the machine had no belly panel, and through time debris had got up under the machine and hit the rotary valve, so much so, the valve became dis engaged from the locator that kept it locked to the lower structure, so that it would stay in a fixed position, when this happened the whole valve started turning, which then ripped off all the hydraulic hoses, you can imagine the following mess, and ofcourse the whole machine was imobilised in the middle of a site, not to mention the oil dump there after !
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  9. #9
    Fabrication Guru +1 v8druid's Avatar
    Join Date
    Apr 2015
    Location
    Druid central, just East of Pandy, Nr. Abergavenny, S. Wales, UK, 3rd rock from the Sun
    Posts
    2,818
    Quote Originally Posted by Muz View Post
    Tell you one severe problem I did have with one of them, dont think its relevant here but just to let you know...For some reason the machine had no belly panel, and through time debris had got up under the machine and hit the rotary valve, so much so, the valve became dis engaged from the locator that kept it locked to the lower structure, so that it would stay in a fixed position, when this happened the whole valve started turning, which then ripped off all the hydraulic hoses, you can imagine the following mess, and ofcourse the whole machine was imobilised in the middle of a site, not to mention the oil dump there after !
    OMG ..... must've been some crap build up to dislodge it from its peg Muz
    If it's got tracks, wheels, t*ts, or an engine, at some point it's gonna give you trouble!!

  10. #10
    Thankfully Iíve got a belly plate. So I changed the servo filter, it wasnít in great order and the new one has helped a bit. When starting to slew it doesnít just take off abruptly which is good. Itís still not very smooth will working at speed though. Must be something to do with oil pressure/flows.

Similar Threads

  1. Possible Slew Braking Issue
    By takeuchi kid in forum Damn! its Broken ........ again ..!!
    Replies: 2
    Last Post: 24-06-2019, 08:52 AM
  2. Kx 71 Slew ring wear. help needed please!
    By Dangermouse74 in forum Everything Excavators
    Replies: 26
    Last Post: 31-10-2018, 07:29 PM
  3. Kubota U -10 slew bearing greaser failure
    By Muz in forum Damn! its Broken ........ again ..!!
    Replies: 2
    Last Post: 30-05-2017, 10:10 PM
  4. Slew motor 801.4
    By Smarttee in forum Everything Excavators
    Replies: 9
    Last Post: 04-04-2017, 07:49 PM
  5. JCB 801 slew problem
    By cartonj in forum Everything Excavators
    Replies: 25
    Last Post: 30-06-2016, 02:59 PM

Tags for this Thread

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •