Results 1 to 2 of 2

Thread: Jcb tm270

  1. #1

    Jcb tm270

    Hi, I have a tm270 in with problems on the tilt. Tilt up is fine, tilt down takes about 5 seconds to work, unless steering is operated or brake is pressed. Stripped the valve and found the o-rings gone on that side of the spool, replaced all and still the same! Checked both tilt pressure relief valves and seem to be ok, swapped and made no difference. Pilot pressure seems ok, swapped pilot pipes and made no difference either, any ideas?
    Thanks

  2. #2
    Fabrication Guru +1 v8druid's Avatar
    Join Date
    Apr 2015
    Location
    Druid central, just East of Pandy, Nr. Abergavenny, S. Wales, UK, 3rd rock from the Sun
    Posts
    2,787
    Quote Originally Posted by andrewpalmer1@live View Post
    Hi, I have a tm270 in with problems on the tilt. Tilt up is fine, tilt down takes about 5 seconds to work, unless steering is operated or brake is pressed. Stripped the valve and found the o-rings gone on that side of the spool, replaced all and still the same! Checked both tilt pressure relief valves and seem to be ok, swapped and made no difference. Pilot pressure seems ok, swapped pilot pipes and made no difference either, any ideas?
    Thanks
    rubber crumb in an orifice somewhere ?
    If it's got tracks, wheels, t*ts, or an engine, at some point it's gonna give you trouble!!

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •