Results 1 to 4 of 4

Thread: Pel Job EB406

  1. #1

    Pel Job EB406

    Hi everyone
    Hope someone can help please.

    I have the above digger Ive owned for 15 years. It has had little use but will be used occasionally.

    Ive recently had problems with it stalling out when I use it. It happens after I use it for a little while.

    Ive changed the diesel filter, washed out the tank and the fuel pump is around 2 years old and I have cleaned out the filter in that too.Ive also checked the pipes between them and they seem ok to me.
    I thought it would have been a fuel issue only but its beyond me now so looking for some help if possible.

    The second speed has also just stopped working.

    It starts OK every time but after a little is stalls. It used to just start back up automatically but I have to switch it off now before it re starts.
    Any help would be grateful and thanks again for your help.

  2. #2
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,499
    Quote Originally Posted by Joneserinio View Post
    Hi everyone
    Hope someone can help please.

    I have the above digger Ive owned for 15 years. It has had little use but will be used occasionally.

    Ive recently had problems with it stalling out when I use it. It happens after I use it for a little while.

    Ive changed the diesel filter, washed out the tank and the fuel pump is around 2 years old and I have cleaned out the filter in that too.Ive also checked the pipes between them and they seem ok to me.
    I thought it would have been a fuel issue only but its beyond me now so looking for some help if possible.

    The second speed has also just stopped working.

    It starts OK every time but after a little is stalls. It used to just start back up automatically but I have to switch it off now before it re starts.
    Any help would be grateful and thanks again for your help.
    Theres an unloader valve on the pump might be stuck .. it means the swash plate is stuck on full delivery all the time which loads the engine. Or .. are any rams stuck at the end of their stroke ?
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

  3. #3
    Quote Originally Posted by Muz View Post
    Theres an unloader valve on the pump might be stuck .. it means the swash plate is stuck on full delivery all the time which loads the engine. Or .. are any rams stuck at the end of their stroke ?
    Thanks Muz

    Turns out it was the fuel pump. Replaced it as I couldnt think of anything else to consider and its fine now. Gutted as I bought the pump originally from volvo

  4. #4
    Admin Muz's Avatar
    Join Date
    Jan 2010
    Location
    Scotland
    Posts
    4,499
    Quote Originally Posted by Joneserinio View Post
    Thanks Muz

    Turns out it was the fuel pump. Replaced it as I couldnt think of anything else to consider and its fine now. Gutted as I bought the pump originally from volvo
    Hmm unusual for them to fail that fast ? Drawing air in a fuel line is another problem to look out for, as part of it is under vaccuum .. just incase youve moved a pipe thats temp sorted it
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

Similar Threads

  1. EB406 electric truoble (puma)
    By Bamse in forum Damn! its Broken ........ again ..!!
    Replies: 3
    Last Post: 12-08-2020, 08:27 AM

Bookmarks

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •