Announcement

Collapse
No announcement yet.

Volvo EC15BXR Drains Battery after 2 hours work

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by NAVDDD View Post
    Today the new Alternator was fitted. Battery still gets drained and conks the engine. I despair, totally flumuxed. Not in a happy place, been trying to see what and why for the last 7.5 hours!
    See my post earlier about an EC 15 keeping running after turning the key off ? well , I noticed after I left the machine for an hour to cool down , when I checked the starter temp it was still hot .. but it wouldnt restart .. just nothing at the switch ... so I left it another hour and was going to drag it out of the way believing the starter to be dead ... but decided to see if it would start, after 2 hours cooling , and it turned over ! it tried to start but the battery was drained ?,.. now ... previously after 3 weeks in sub zero it started no problem 1st time ? So that seems very odd to me ? It had power at first start in the cold ... but becase the starter had been kept running it drained the battery ... no doubt. Sometimes the solenoid sticks and the engine runs the starter, but on this occasion I believe the starter had been constantly energised
    Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

    Comment


    • #17
      Thank you Muz. The starter doesn't whir to my knowledge, though this will be checked.

      I'm looking at everything and anything and will revisit previously assumed as being ok. For example, the workaround for the SW9 and SW10 arm switches and even looking at trying to repair the old switches tat had been there to! ha ha.

      Comment


      • #18
        Originally posted by NAVDDD View Post
        Thank you Muz. The starter doesn't whir to my knowledge, though this will be checked.
        You cant hear if its engaged or not though (at least I couldnt)

        Please don't PM me for plant advice.. thanks .. Post in the forum where I will gladly help, as will many of our contributors.. as the info and responses will help everyone else, which is why we exist

        Comment


        • #19
          Originally posted by Muz View Post

          You cant hear if its engaged or not though (at least I couldnt)
          Thank you, I understand.

          I checked out your tread : Starter Engages
          This morning I ran the engine (for half and hour) and slipped my hand around a very hot exhaust manifold and onto the starter which was cool and gave no temperture indication of being constantly engaged.

          I've got a "digger mechanic" coming the end of next week to see what can be done. I'm willing to try/check any further suggetions.

          Comment

          Working...
          X